Docker Hub API v1 (устаревший)

Предупреждение

Устарело

Docker Hub API v1 устарел. Вместо этого используйте Docker Hub API v2.

Следующие маршруты API в пути v1 больше не будут работать и будут возвращать код состояния 410:

  • /v1/repositories/{name}/images

  • /v1/repositories/{name}/tags

  • /v1/repositories/{name}/tags/{tag_name}

  • /v1/repositories/{namespace}/{name}/images

  • /v1/repositories/{namespace}/{name}/tags

  • /v1/repositories/{namespace}/{name}/tags/{tag_name}

Если вы хотите продолжать использовать Docker Hub API в своих текущих приложениях, обновляет свои клиенты, чтобы они использовали конечные точки версии 2.

СТАРЫЙ

НОВЫЙ

/v1/repositories/{name}/images

/v2/namespaces/{namespace}/repositories/{repository}/images

/v1/repositories/{namespace}/{name}/images

/v2/namespaces/{namespace}/repositories/{repository}/images

/v1/repositories/{name}/tags

/v2/namespaces/{namespace}/repositories/{repository}/tags

/v1/repositories/{namespace}/{name}/tags

/v2/namespaces/{namespace}/repositories/{repository}/tags

/v1/repositories/{namespace}/{name}/tags

/v2/namespaces/{namespace}/repositories/{repository}/tags/{tag}

/v1/repositories/{namespace}/{name}/tags/{tag_name}

/v2/namespaces/{namespace}/repositories/{repository}/tags/{tag}